Aller au contenu
SkyFo

Problème de loop all players

Messages recommandés

Bonjour, j'ai un problème avec les loop all players. Dès que je vais loop all player, si un joueur à la variable en true alors exécuter l'action. Sauf que j'ai fais en sorte que plusieurs joueurs ont une variable en true, et le loop all player sélectionne uniquement 1 joueur qui à la variable en true alors qu'il y en a d'autre !

 

PS : Dans la description est indiqué la notion de warp (c'est un projet) mais pour l'instant j'ai fais cela sous forme de message et uniquement 1 joueur reçois un message parmi les autres. Bien sûr, ils ont la variable en true, et ce qui ne sont pas en true ne reçoivent pas le message.

Version de Minecraft : 1.12.2
Version de Skript : 2.2

Type du skript : Faire spawner les joueurs dans 5 warps (voir dans le script). Faire spawn uniquement les players qui ont fait un clique droit sur la pancarte après un timing.

Description du script :

Dans ce script, 1 player doit cliquer sur une pancarte pour accèder à un lobby du jeux 1 (dans la map). Dès que 5 players ont rejoins le lobby du jeux1, après un certain temps, les joueurs doivents être rediriger vers différents warps. (Problème que je rencontre. J'ai fais un système de variable et 1 player sur les 5 est téléporter.)

Contenu masqué

    Réagissez ou répondez à ce message afin de consulter le contenu masqué.

Contenu masqué

    Réagissez ou répondez à ce message afin de consulter le contenu masqué.

Partager ce message


Lien à poster
Partager sur d’autres sites

Ton loop a bien loop tout les joueurs mais tu as incrémenté le wait 60 seconds dans ton loop du coup tout les joueurs loops recevront le message toute les 60 secondes à par le premier qui le recevra instant et stp envoie pas de fichier quand les skripts ils sont courts donne les directement dans ton topic.

Voila le problème est réglé

Contenu masqué

    Réagissez ou répondez à ce message afin de consulter le contenu masqué.

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci beaucoup de ton aide, je vais tester tout ça, et ok pour ne pas upload des petits script.

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 21/07/2020 à 12:58, Px_MgeaFR a dit :

Bonjour @SkyFo, je viens de trouver 3 erreurs présentes dans le skript de @zarco70.
 

Contenu masqué

    Réagissez ou répondez à ce message afin de consulter le contenu masqué.

Cordialement @Px_MgeaFR

Merci beaucoup !

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

×
×
  • Créer...

Information importante

Nous avons placé des cookies sur votre appareil pour aider à améliorer ce site. Vous pouvez choisir d’ajuster vos paramètres de cookie, sinon nous supposerons que vous êtes d’accord pour continuer.