Aller au contenu

1 Screenshot

About This File

Bien l'bonjour !

Voici un nouveau petit script très sympa, pour ajouter un calendrier de l'avent a votre serveur ! Eh ouais, c'est bientôt noël (enfin dans 1 mois), mais il faut déjà se préparer ! Si j'ai mis la ressource si en avant, c'est de 1 parce que sinon j'allais oublier x), et aussi pour que vous me fassiez part de divers bugs si vous en trouvez !

Description

C'est un script très simple ! Les joueurs ont juste 1 commande, /calendrier. Ca leur ouvre le calendrier ! Ils peuvent ouvrir la suprise du jour, si on est en décembre ! Sinon il y aura un petit message qui leur dis d'attendre 😉 S'il décide de ne pas ouvrir la surprise au jour le jour, mais par exemple d'attendre 1 semaine pour en avoir 7 d'un coup, ils peuvent ! Mais il faudra cependant les ouvrir dans l'ordre 😉. Les items, c'est vous qui choisissez ! Vous pouvez en mettre jusqu'a 44 par surprise, et un petit tirage sera effectué ! (voir gifs plus bas)

Commandes

/calendrier ou /cal : ouvrir le calendrier de l'avent !
            Permission : aucune

/admincalendrier ou /acal [nombre] : Ouvrir l'éditeur de surprise ! Très facile a utiliser ;) Si vous décidez de mettre un nombre, vous ouvrirai l'éditeur de surprise du jour indiqué ! Il permet aussi de modifier l'affichage.
            Permission : calendrier.admin

 

Screens

723065217_Capturedcran2018-11-0213_29_22.png.df3aeeee0975b03e41d5e74fff46f81e.png

Message quand on rejoint le serveur, et qu'on a pas ouvert la surprise du jour !

1152168301_Capturedcran2018-11-0213_31_47.png.7be50c5e30d328aabf38a22e2442da6c.png

Différents messages d'erreur.
1 : quand on veut ouvrir une surprise mais qu'on a pas ouvert celle d'avant
2 : Quand on veut ouvrir une surprise alors que ce n'est pas encore le jour
3 : Quand on est après le 24 décembre
4 : Quand on est pas/plus en décembre

 

Screen%20Recording%202018-11-02%20at%200

Gif quand on ouvre des surprises ! On est le 2, alors je peux ouvrir celle du 1 que je n'avais pas encore débloquée, et celle du 2. Je ne peux pas ouvrir la 3, 4, 5 car on est pas encore le 3, 4, 5, et je ne peux pas ouvrir celles d'après car je n'ai pas défini d'item ! Aussi, l'affichage est "linéaire".
image.png.3ce18cb6351f5f915699ea36a066778d.png
Image de l'affichage en "arbre". Il peut être modifié dans le /admincal.
Précision : Vous pouvez suivre les instructions de la ligne 126 pour ajouter votre propre disposition. SI vous avez besoin d'aide pour cela, n'hésitez pas a me contacter par discord noftaly#0359 ou par MP forum 😉

Addons

Il vous faut :
Skript 2.2-dev36 minimum (pour les fonctions, le temps, et les expressions ternaires)
- SkQuery-Lime (pour diverses fonctionnalités)
- TuSKe (pour les GUIs)

Testé avec :
- Skript 2.2-dev37c
- SkQuery-Lime 3.6.1-Lime
- TuSKe 1.8.2-pikachu-patch-3
- Spigot 1.12
- Java 8

Fin

Et voilà ! Si vous avez des idées, n'hésitez surtout pas a me les dires, par discord (noftaly#0359) ou MP forum ! Idem pour les bugs 😉
Si vous avez aimez, likez 🙂 et notez 
★★★★★ !

Merci beaucoup 😉


What's New in Version 1.2   See changelog

Released

+ Recode du système d'affichage des surprises
+ Ajout de la possibilité de choisir l'affichage des surprises
+ Suppression d'une ligne inutile
1.2.1 + Ajout d'instructions pour créer votre propre disposition

  • J'aime 2



Retour utilisateur

Commentaires recommandés



Je n'ai pas testé mais j’approuve car c'est orginal... c'est autonome...

Partager ce commentaire


Lien vers le commentaire
Partager sur d’autres sites
il y a 28 minutes, CapitaineMatteo a dit :

Je n'ai pas testé mais j’approuve car c'est orginal... c'est autonome...

Alors je t'invite a le noter 😉 ★★★★★

Partager ce commentaire


Lien vers le commentaire
Partager sur d’autres sites

La tu es dans l'onglet "Comments"

Tu dois télécharger le fichier, puis tu vas dans l'onglet "Review", puis tu notes 😉

Partager ce commentaire


Lien vers le commentaire
Partager sur d’autres sites

Quand je fait /admincalendrier sa m'ouvre un menu vide et sa m'écris dans le chat "An internal error occurred while attempting to perform this command"

Partager ce commentaire


Lien vers le commentaire
Partager sur d’autres sites

@MaxDu56YT Il me faudrait ta version skript (/ver Skript), ta version TuSKe (/ver tuske), ta version SkQuery (/ver skquery) et ta version minecraft (/ver) 🙂

Modifié par noftaly

Partager ce commentaire


Lien vers le commentaire
Partager sur d’autres sites

Version skript : 2.3-beta2
Version TuSKe : 1.8.2-Pikachu-patch-3

Version skquery ; 3.6.1-Lime

Version minecraft ; 1.13.2 spigot

@noftaly

Modifié par MaxDu56YT

Partager ce commentaire


Lien vers le commentaire
Partager sur d’autres sites
il y a 12 minutes, MaxDu56YT a dit :

Version skript : 2.3-beta2
Version TuSKe : 1.8.2-Pikachu-patch-3

Version skquery ; 3.6.1-Lime

Version minecraft ; 1.13.2 spigot

@noftaly

Ce doit être a cause de la 1.13 et de skript 2.3-beta2. Désolé, mais vu que c'est encore une bêta tous les addons ne sont pas a jours, et je ne compte pas rendre le script compatible (j'attendrai une version stable officielle) 😞

Modifié par noftaly

Partager ce commentaire


Lien vers le commentaire
Partager sur d’autres sites
il y a 7 minutes, noftaly a dit :

Ce doit être a cause de la 1.13 et de skript 2.3-beta2. Désolé, mais vu que c'est encore une bêta tous les aidons ne sont pas a jours, et je ne compte pas rendre le script compatible (j'attendrai une version stable officielle) 😞

D'accord merci quand même

Partager ce commentaire


Lien vers le commentaire
Partager sur d’autres sites

@MaxDu56YT il faut savoir qu'une review c'est là pour vérifier que le script fonctionne correctement, et le tester de A à Z, et pas seulement regarder s'il s'est chargé sans erreurs 😂

Partager ce commentaire


Lien vers le commentaire
Partager sur d’autres sites
Le 07/11/2018 à 20:34, AlexLew a dit :

@MaxDu56YT il faut savoir qu'une review c'est là pour vérifier que le script fonctionne correctement, et le tester de A à Z, et pas seulement regarder s'il s'est chargé sans erreurs 😂

J'ai tester en 1.12.2 et le soucis c'est que sa fait pareil 😕 @noftaly

Modifié par MaxDu56YT

Partager ce commentaire


Lien vers le commentaire
Partager sur d’autres sites
Le 12/11/2018 à 00:35, MaxDu56YT a dit :

J'ai tester en 1.12.2 et le soucis c'est que sa fait pareil 😕 @noftaly

Avec quelle version skript (/ver Skript), version TuSKe (/ver tuske), et version SkQuery (/ver skquery) ?

Partager ce commentaire


Lien vers le commentaire
Partager sur d’autres sites
il y a 25 minutes, noftaly a dit :

Avec quelle version skript (/ver Skript), version TuSKe (/ver tuske), et version SkQuery (/ver skquery) ?

version skript : 2.3-beta2 

version TuSKe 1.8.2-Pikachu-Patch-3 

version SkQuery 3.6.1-Lime 

Faut que je garde les mêmes ? 

Partager ce commentaire


Lien vers le commentaire
Partager sur d’autres sites
Il y a 18 heures, MaxDu56YT a dit :

2.3-beta2 

que tu sois en 1.13 ou en 1.12, mon script s'en fiche, ce qui compte c'est la version de skript, et si tu utilises la même il y aura les mêmes bugs 🤷‍♂️ 😂

En 1.12 il faut utiliser la dev37c

Partager ce commentaire


Lien vers le commentaire
Partager sur d’autres sites
Le 15/11/2018 à 14:23, noftaly a dit :

que tu sois en 1.13 ou en 1.12, mon script s'en fiche, ce qui compte c'est la version de skript, et si tu utilises la même il y aura les mêmes bugs 🤷‍♂️ 😂

En 1.12 il faut utiliser la dev37c

D'accord j'ai juste à changer la version de skript et sa ira mieux les autres addons pas besoin de l'ai modifier ?

Partager ce commentaire


Lien vers le commentaire
Partager sur d’autres sites
il y a 2 minutes, MaxDu56YT a dit :

D'accord j'ai juste à changer la version de skript et sa ira mieux les autres addons pas besoin de l'ai modifier ?

Nan c'est bon tu as déjà leur dernière version

Partager ce commentaire


Lien vers le commentaire
Partager sur d’autres sites
Le 07/11/2018 à 14:32, noftaly a dit :

@MaxDu56YT Il me faudrait ta version skript (/ver Skript), ta version TuSKe (/ver tuske), ta version SkQuery (/ver skquery) et ta version minecraft (/ver) 🙂

Bonsoir, j'ai pris la dernière version du skript calendrier 1.2.1 est bas sa m'affiche rien dans le menu du /calendrier 😕

J'ai 12 errors sur ce skript 

 

Partager ce commentaire


Lien vers le commentaire
Partager sur d’autres sites

Exactement le même discours qu'avant

Il y a 12 heures, MaxDu56YT a dit :

Il me faudrait ta version skript (/ver Skript), ta version TuSKe (/ver tuske), ta version SkQuery (/ver skquery) et ta version minecraft (/ver)

 

Partager ce commentaire


Lien vers le commentaire
Partager sur d’autres sites
il y a 8 minutes, noftaly a dit :

Exactement le même discours qu'avant

 

/ver Skript = 2.2-dev37c 

/ver tuske = 1.8.2-Pikachu-Patch-3 

/ver skquery = 3.6.1-Lime 

/ver = spigot 1.12.2

 

Partager ce commentaire


Lien vers le commentaire
Partager sur d’autres sites
à l’instant, noftaly a dit :

Envoie les erreurs stp

/sk reload calendrier v1.2.1
§7[§6Skript§7]§r Reloading §6calendrier v1.2.1.sk§r... 
Can't understand this condition/effect: format gui slot 45, 46, 47, 48, 50, 51, 52 of {_p} with light blue stained glass pane (calendrier v1.2.1.sk, line 25: format gui slot 45, 46, 47, 48, 50, 51, 52 of {_p} with light blue stained glass pane') 
can't understand this condition: 'format gui slot 49 of {_p} with gold block named "&eCliquer ici avec un item pour l'ajouter" to run' (calendrier v1.2.1.sk, line 26: format gui slot 49 of {_p} with gold block named "&eCliquer ici avec un item pour l'ajouter" to run:') 
can't understand this condition: 'format gui slot 45 of {_p} with arrow named "&cRetour" to run' (calendrier v1.2.1.sk, line 39: format gui slot 45 of {_p} with arrow named "&cRetour" to run:') 
can't understand this condition: 'format gui slot 51 of {_p} with redstone dust item named "&cTout supprimer" to run' (calendrier v1.2.1.sk, line 41: format gui slot 51 of {_p} with redstone dust item named "&cTout supprimer" to run:') 
Can't understand this condition/effect: format gui slot 53 of {_p} with barrier named "&cFermer" to close (calendrier v1.2.1.sk, line 44: format gui slot 53 of {_p} with barrier named "&cFermer" to close') 
can't understand this condition: 'format gui slot (integers from 0 to 35) of {_p} with light green stained glass pane named "&aBravo !" to run' (calendrier v1.2.1.sk, line 62: format gui slot (integers from 0 to 35) of {_p} with light green stained glass pane named "&aBravo !" to run:') 
Can't understand this condition/effect: format gui slot 4 of player with paper named "&eNous sommes le &6%{_ajrd}%%(""er"") if {_ajrd} = 1, else """"% &edécembre !" (calendrier v1.2.1.sk, line 86: format gui slot 4 of player with paper named "&eNous sommes le &6%{_ajrd}%%(""er"") if {_ajrd} = 1, else """"% &edécembre !"') 
can't understand this condition: 'format gui slot {_loopvalue} of player with ender chest named "&cSurprise du %{_day}% !" with lore "&r||%(""&e&oAujourd'hui"") if {_day} = {_ajrd}, else (""&e&oPas encore ouverte !"")%" to run' (calendrier v1.2.1.sk, line 94: format gui slot {_loopvalue} of player with ender chest named "&cSurprise du %{_day}% !" with lore "&r||%(""&e&oAujourd'hui"") if {_day} = {_ajrd}, else (""&e&oPas encore ouverte !"")%" to run:') 
can't understand this condition: 'format gui slot {_loopvalue} of player with chest named "&cSurprise du %{_day}% !" to run' (calendrier v1.2.1.sk, line 97: format gui slot {_loopvalue} of player with chest named "&cSurprise du %{_day}% !" to run:') 
can't understand this condition: 'format gui slot {_loopvalue} of player with chest named "&7Surprise du %{_day}% !" with lore "||&7&l&m-----------&c ⚠ &7&l&m-----------||&c&lImpossible de la récuperer !||&c&lDites aux admins de définir||&c&lune surprise !" to run' (calendrier v1.2.1.sk, line 100: format gui slot {_loopvalue} of player with chest named "&7Surprise du %{_day}% !" with lore "||&7&l&m-----------&c ⚠ &7&l&m-----------||&c&lImpossible de la récuperer !||&c&lDites aux admins de définir||&c&lune surprise !" to run:') 
can't understand this condition: 'format gui slot 4 of player with paper named "&eAffichage des surprises" with lore "%{_lore}%" to run' (calendrier v1.2.1.sk, line 134: format gui slot 4 of player with paper named "&eAffichage des surprises" with lore "%{_lore}%" to run:') 
'::admin::%{_lv}%::*}% &citem%(""s"") if size of {cal::admin::%{_lv}%::*} > 1, else """"%" to run' is not a valid item data (calendrier v1.2.1.sk, line 141: format gui slot (9 + loop-value - 1) of player with chest named "&cSurprise du %loop-value% !" with lore "&e&l%size of {cal::admin::%{_lv}%::*}% &citem%(""s"") if size of {cal::admin::%{_lv}%::*} > 1, else """"%" to run:') 
§7[§6Skript§7]§r §4Encountered 12 errors while reloading §6calendrier v1.2.1.sk§r! 

 

Partager ce commentaire


Lien vers le commentaire
Partager sur d’autres sites

Tu es sur et certain a 100% que les versions que tu m'a données sont vraiment les bonnes ? Parce que ce n'est pas normal ca... Et avec les versions que j'ai (les mêmes que les tienne) je n'ai pas d'erreur...

Partager ce commentaire


Lien vers le commentaire
Partager sur d’autres sites
il y a 1 minute, noftaly a dit :

Tu es sur et certain a 100% que les versions que tu m'a données sont vraiment les bonnes ? Parce que ce n'est pas normal ca... Et avec les versions que j'ai (les mêmes que les tienne) je n'ai pas d'erreur...

Heu oui, après le mieux aurait tu discord ?

Partager ce commentaire


Lien vers le commentaire
Partager sur d’autres sites

oui  noftaly#0359

Modifié par noftaly

Partager ce commentaire


Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×

Information importante

Nous avons placé des cookies sur votre appareil pour aider à améliorer ce site. Vous pouvez choisir d’ajuster vos paramètres de cookie, sinon nous supposerons que vous êtes d’accord pour continuer.